aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..8acb130
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+import setuptools
+
+with open("README.md", "r") as fh:
+ long_description = fh.read()
+
+setuptools.setup(
+ name="GANtools",
+ version="0.0.1",
+ author="Vee9ahd1",
+ author_email="[email protected]",
+ description="cli tools for image generation w bigGAN",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ url="https://gitlab.com/Vee9ahd1/gantools",
+ packages=setuptools.find_packages(),
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: GPL",
+ "Operating System :: OS Independent",
+ ],
+ )